New Wallet release addressing the “Fake Stake” attack issue on chain-based PoS cryptocurrencies

Colossusˣᵗ Team

We are happy to announce that a new non-mandatory Wallet v1.2.1 has been published, mainly addressing exchanges regarding the “Fake Stake” attack issues.

These vulnerabilities have affected 26+ Proof-of-Stake cryptocurrencies in total and would allow a network attacker with a very small amount of stake to crash any of the network nodes running the corresponding software.

You can find more info about this issue in a medium article published by Decentralized Systems Lab here.

stake amplification step

stake amplification step

 

Announcement for CryptoBridge is expected to follow shortly.

Translate »